Turning Clash Queue Back On
Incident Report for Hi-Rez Studios, Inc
Resolved
Clash Queue is now back on, you will have to re log your client to see it
#SMITE
Posted almost 2 years ago. Dec 18, 2015 - 08:37 EST
Investigating
We require a restart of a component in the game, Matches will not be able to be launched during this time and new logins will be limited for a few minutes #SMITE
Posted almost 2 years ago. Dec 18, 2015 - 08:26 EST