Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency Restart of #Smite #PC has been completed.
Posted 18 days ago. Jul 05, 2017 - 12:21 EDT
Identified
We are going to perform an Emergency Restart of #Smite #PC
Posted 18 days ago. Jul 05, 2017 - 12:15 EDT
This incident affected: Smite PC - North America / Europe.