Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have corrected an issue with #Smite PC and are continuing to monitor.
Posted 16 days ago. Jun 08, 2017 - 23:34 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 16 days ago. Jun 08, 2017 - 23:12 EDT
This incident affected: Smite PC - North America / Europe.