Realm Royale Crossplay emergency restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 days ago. Mar 09, 2019 - 13:37 EST
Monitoring
The restart has been completed.
Posted 10 days ago. Mar 09, 2019 - 13:10 EST
Investigating
We are performing an emergency restart on Realm Royale Crossplay.
Posted 10 days ago. Mar 09, 2019 - 12:51 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale Xbox).