Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart of #Smite #PC has been completed and we have resumed log ins
Posted 3 months ago. Jul 05, 2017 - 16:04 EDT
Monitoring
We will be restarting #Smite #PC momentarily and will continue to monitor.
Posted 3 months ago. Jul 05, 2017 - 15:51 EDT
Identified
We have identified an issue with #Smite #PC and are investigating
Posted 3 months ago. Jul 05, 2017 - 15:49 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Jul 05, 2017 - 15:45 EDT
This incident affected: Smite PC - North America / Europe.