Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 28, 2017 - 18:32 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Jan 28, 2017 - 18:22 EDT
This incident affected: Paladins PC.