Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 11 months ago. Sep 25, 2016 - 05:15 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 11 months ago. Sep 25, 2016 - 04:17 EDT