Paladins Strike Log Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 03:42 EST
Monitoring
Logins have resumed on Paladins Strike and we're keeping an eye on things.
Posted Nov 15, 2019 - 03:16 EST
Investigating
We're investigating the Login Issues for Paladins Strike
Posted Nov 15, 2019 - 03:04 EST
This incident affected: Paladins Strike (Paladins Strike Mobile).