Paladins Switch Login Issue.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Feb 08, 2021 - 11:39 EST
Investigating
#Paladins #Switch players will be unable to login and play. We have identified the issue, and working through a fix. Thank you, and we apologize for the incovienance.
Posted Feb 03, 2021 - 13:00 EST
This incident affected: Paladins (Paladins Switch).