We are experiencing connectivity issues with all of our game environments.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Dec 28, 2015 - 13:07 EST
Investigating
We are currently investigating the situation.
Posted over 1 year ago. Dec 26, 2015 - 12:45 EST