Smite PS4 Log-in issues.
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Smite #PS4 log-in issue has been resolved.
Posted 4 months ago. May 05, 2019 - 15:50 EDT
Monitoring
A fix has been implemented for #Smite #PS4 log-ins, we are monitoring.
Posted 4 months ago. May 05, 2019 - 15:05 EDT
Investigating
We are currently investigating #Smite #PS4 log-in issues.
Posted 4 months ago. May 05, 2019 - 14:54 EDT
This incident affected: Smite (Smite PS4).