Smite Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 15, 2019 - 05:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Mar 15, 2019 - 05:42 EDT
Identified
We are performing an emergency on #Smite #PC #Xbox #PS4 #Switch to address the issue.
Posted 2 months ago. Mar 15, 2019 - 04:23 EDT
Investigating
We are currently investigating a login issue with #Smite #PC #Xbox #PS4 #Switch
Posted 2 months ago. Mar 15, 2019 - 04:20 EDT
This incident affected: Smite (Smite PC, Smite PS4, Smite Xbox, Smite Switch).