Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency restart of #Paladins PC is complete.
Posted 8 months ago. Apr 07, 2017 - 14:04 EDT
Identified
We will be restarting the Paladins PC enviroment. Game will be back up shortly.
Posted 8 months ago. Apr 07, 2017 - 13:48 EDT
Monitoring
Emergency restart of #Paladins PC is complete and logins have been re-enabled; continuing to monitor.
Posted 8 months ago. Apr 07, 2017 - 13:36 EDT
Identified
We are performing an emergency restart of #Paladins PC; game will be back shortly.
Posted 8 months ago. Apr 07, 2017 - 13:31 EDT
Update
We are currently looking into issues with Paladins PC
Posted 8 months ago. Apr 07, 2017 - 13:20 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 months ago. Apr 07, 2017 - 13:15 EDT
This incident affected: Paladins PC.