Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency restart has been completed for #Smite #PC
Posted 4 months ago. Mar 05, 2017 - 03:14 EST
Identified
We are working to restore logins on #Smite #PC
Posted 4 months ago. Mar 05, 2017 - 02:47 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 4 months ago. Mar 05, 2017 - 02:39 EST
This incident affected: Smite PC - North America / Europe.