Paladins Strike Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 11, 2019 - 23:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Apr 11, 2019 - 22:02 EDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Apr 11, 2019 - 21:00 EDT
This incident affected: Paladins Strike (Paladins Strike Mobile).