Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PC has been resolved.
Posted Sep 11, 2017 - 20:59 EDT
Monitoring
The restart of #Paladins #PC has been completed. We are monitoring the results.
Posted Sep 11, 2017 - 20:39 EDT
Identified
We are performing an emergency restart of #Paladins #PC. The game will be back up shortly.
Posted Sep 11, 2017 - 19:49 EDT
Update
We are currently investigating the issue with #Paladins #PC
Posted Sep 11, 2017 - 19:44 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Sep 11, 2017 - 19:39 EDT
This incident affected: Paladins (Paladins PC).