Smite PS4 Match Making Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 28, 2016 - 16:51 EDT
Investigating
We are currently aware of match-making issues effecting #Smite on #PS4.
Posted 8 months ago. Oct 28, 2016 - 16:36 EDT