Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues with #Paladins PC have been resolved; continuing to monitor for stability.
Posted 8 months ago. Oct 29, 2016 - 14:09 EDT
Monitoring
#Paladins PC experienced an issue with Matches launching and player logins; we believe the issue has been corrected; continuing to monitor.
Posted 8 months ago. Oct 29, 2016 - 13:58 EDT
Update
We are aware and investigating an issue with Paladins PC causing users to re-login...
Posted 8 months ago. Oct 29, 2016 - 13:34 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 months ago. Oct 29, 2016 - 13:27 EDT