Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #smite
Posted 11 months ago. Dec 10, 2016 - 10:03 EST
Update
We are going to perform a restart if smite pc#smite
Posted 11 months ago. Dec 10, 2016 - 09:49 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 11 months ago. Dec 10, 2016 - 09:43 EST