Realm Royale PC and XBox Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 29, 2019 - 18:48 EST
Identified
We will be performing an emergency restart of Realm Royale for PC and XBox momentarily.
Posted 3 months ago. Jan 29, 2019 - 18:43 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale Xbox).