Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOX incident has been resolved #Smite XBOX
Posted 6 months ago. Feb 20, 2017 - 22:45 EST
Update
Investigating: We are currently investigating this Smite XBOX issue. #SmiteXBOX
Posted 6 months ago. Feb 20, 2017 - 22:06 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 6 months ago. Feb 20, 2017 - 21:55 EST
This incident affected: Smite Xbox - North America / Europe.