Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 11 months ago. Apr 24, 2016 - 17:15 EDT
Update
Smite PC Steam users may experience trouble with login
http://downdetector.com/status/steam #smite
Posted 11 months ago. Apr 24, 2016 - 15:54 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 11 months ago. Apr 24, 2016 - 15:41 EDT