Smite PC Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC login issue has been resolved.
Posted 3 months ago. Jul 02, 2018 - 09:36 EDT
Monitoring
The restart has been completed and logins have resumed! #Smite #PC
Posted 3 months ago. Jul 02, 2018 - 08:41 EDT
Update
We are performing an emergency restart on #Smite #PC
Posted 3 months ago. Jul 02, 2018 - 08:20 EDT
Update
We are limiting logins for #Smite #PC while we continue to investigate the issue.
Posted 3 months ago. Jul 02, 2018 - 08:16 EDT
Investigating
We are investigating an issue affecting #Smite #PC Logins.
Posted 3 months ago. Jul 02, 2018 - 08:09 EDT
This incident affected: Smite (Smite PC).