Paladins Crossplay Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 17, 2019 - 15:49 EDT
Investigating
We are investigating an issue preventing players from being able to log in and queue for game modes
Posted about 1 month ago. Jul 17, 2019 - 15:12 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).