Smite PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 02, 2019 - 19:28 EDT
Investigating
We are performing an emergency restart of Smite on PS4
Posted 4 months ago. Jul 02, 2019 - 19:19 EDT
This incident affected: SMITE (SMITE PS4).