Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Smite#PC emergency restart has been completed. We are monitoring the results.
Posted 18 days ago. Aug 03, 2018 - 03:40 EDT
Investigating
We are performing an emergency restart for #Smite #PC. Game will be back up soon.
Posted 18 days ago. Aug 03, 2018 - 03:19 EDT
This incident affected: Smite (Smite PC).