Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins #PC issue has been resolved
Posted about 2 months ago. Aug 10, 2017 - 04:31 EDT
Monitoring
Services are recovering and we are currently monitoring #Paladins #PC
Posted about 2 months ago. Aug 10, 2017 - 04:21 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Aug 10, 2017 - 04:12 EDT
This incident affected: Paladins PC.