Paladins PS4 Emergency restart.
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins #PS4 is back online. We will continue to monitor.
Posted 3 months ago. May 17, 2019 - 12:45 EDT
Investigating
We are performing an emergency restart for #Paladins #PS4.
Posted 3 months ago. May 17, 2019 - 12:36 EDT
This incident affected: Paladins (Paladins PS4).