All Smite Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Sep 09, 2019 - 04:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2019 - 03:57 EDT
Investigating
We will be performing an emergency restart on all of Smite. We apologize for the inconvenience and will have the game back up shortly.
Posted Sep 09, 2019 - 03:28 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).