Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues with #SMITE #PC have been resolved.
Posted about 1 month ago. May 10, 2017 - 22:56 EDT
Identified
We are currently looking into issues with #SMITE #PC
Posted about 1 month ago. May 10, 2017 - 22:35 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 month ago. May 10, 2017 - 22:31 EDT
This incident affected: Smite PC - North America / Europe.