Smite PC/XBOX/PS4 Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC, #PS4, and #Xbox issue has been resolved.
Posted 3 months ago. May 30, 2018 - 17:07 EDT
Monitoring
We have enabled logins for XBOX and PS4. We are continuing to monitor.
Posted 3 months ago. May 30, 2018 - 16:27 EDT
Update
We made changes in Smite PC for 5.9 that we hope will fix the problems. The environment is back open. Consoles are pending results from PC
Posted 3 months ago. May 30, 2018 - 15:35 EDT
Update
The number of problems was too high for us to keep the environments up. We are tracking down the root problem now.
Posted 3 months ago. May 30, 2018 - 14:02 EDT
Investigating
We are experiencing some problems with the 5.9 patch in all 3 environments, including sporadic issues with purchases and acquisitions. We will likely have restarts soon to address and we will work to fix any players missing items.
Posted 3 months ago. May 30, 2018 - 13:16 EDT
This incident affected: Smite (Smite PC, Smite PS4, Smite Xbox).