Paladins PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. May 13, 2019 - 09:31 EDT
Monitoring
Paladins PS4 is back online. We will continue to monitor.
Posted 3 months ago. May 12, 2019 - 23:25 EDT
Identified
We will be performing an emergency restart of Paladins PS4 to address an issue with logins. The game will be back shortly.
Posted 3 months ago. May 12, 2019 - 23:19 EDT
This incident affected: Paladins (Paladins PS4).