Loggin Issues For All Platforms and Games
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Dec 22, 2015 - 23:18 EDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Dec 22, 2015 - 23:11 EDT