Smite PC server issues with 2.20 update
Incident Report for Hi-Rez Studios, Inc
Resolved
The restart has been completed and the fixes have been confirmed for smite on PC.
#Smite
Posted over 1 year ago. Dec 15, 2015 - 12:39 EST
Identified
We have identified the issue that is keeping us from bringing Smite PC back up. We are now forecasting being up at 1130am EST. #smite
Posted over 1 year ago. Dec 15, 2015 - 10:37 EST