Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Dec 18, 2016 - 19:56 EST
Identified
We are currently working to restore Match Making services for #Paladins on #PC.
Sorry for the inconvenience.
Posted 5 months ago. Dec 18, 2016 - 16:53 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. Dec 18, 2016 - 16:46 EST