Realm Royale emergency maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RealmRoyale emergency maintenance has been completed.
Posted 17 days ago. Oct 31, 2018 - 11:58 EDT
Identified
We are performing an emergency maintenance on #RealmRoyale.
Posted 17 days ago. Oct 31, 2018 - 11:50 EDT
This incident affected: Realm Royale (Realm Royale PC).