Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #PaladinsPC
Posted 5 months ago. May 15, 2017 - 22:27 EDT
Identified
We are pausing logins for a few moments on Paladins PC #PaladinsPC
Posted 5 months ago. May 15, 2017 - 22:19 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. May 15, 2017 - 22:13 EDT
This incident affected: Paladins PC.