Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
All games have recovered. We are continuing to monitor.
Posted 5 months ago. Mar 13, 2018 - 01:06 EDT
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted 5 months ago. Mar 13, 2018 - 00:10 EDT
This incident affected: Paladins (Paladins PS4, Paladins Xbox) and Smite (Smite PS4, Smite Xbox).