Realm Royale PS4
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 13 days ago. Sep 09, 2019 - 04:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 13 days ago. Sep 09, 2019 - 03:56 EDT
Investigating
We will be performing an emergency restart on Realm Royale PS4. We apologize for the inconvenience and will have the game back up shortly.
Posted 13 days ago. Sep 09, 2019 - 03:30 EDT
This incident affected: Realm Royale (Realm Royale PS4).