Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #Paladins PC
Posted 10 days ago. Jun 15, 2017 - 15:15 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 10 days ago. Jun 15, 2017 - 14:01 EDT
This incident affected: Paladins PC.