All Games Networking Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite #paladins all network issues appeared to be resolved
Posted about 1 year ago. May 27, 2016 - 11:30 EDT
Monitoring
#Smite #paladins - the networking issue appears to be resolving. We are monitoring
Posted about 1 year ago. May 27, 2016 - 11:06 EDT
Update
#Smite #Paladins all games are now affected with a networking issue
Posted about 1 year ago. May 27, 2016 - 10:47 EDT
Update
#Smite there are network issues affecting PC and XBOX users
Posted about 1 year ago. May 27, 2016 - 10:39 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. May 27, 2016 - 10:33 EDT