Login Issues on Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Dec 16, 2015 - 09:09 EST
Identified
We are restarting the servers
Posted almost 2 years ago. Dec 16, 2015 - 08:43 EST
Investigating
We are investigating
Posted almost 2 years ago. Dec 16, 2015 - 08:23 EST