Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins PC has been resolved.
Posted May 27, 2017 - 08:44 EDT
Monitoring
We have mitigated an issue with #Paladins PC and are continuing to monitor.
Posted May 27, 2017 - 08:34 EDT
Identified
we have identified an issue with #Paladins PC and are working to address
Posted May 27, 2017 - 08:32 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted May 27, 2017 - 08:18 EDT
This incident affected: Paladins (Paladins PC).