Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The incident has been resolved for #Smite #Xbox
Posted 5 months ago. May 19, 2017 - 18:37 EDT
Identified
We are looking into issues with #Smite #Xbox
Posted 5 months ago. May 19, 2017 - 17:21 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 5 months ago. May 19, 2017 - 17:16 EDT
This incident affected: Smite Xbox - North America / Europe.