Smite PC Limited logins
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved.#smite
Posted about 1 year ago. Sep 14, 2016 - 15:39 EDT
Investigating
We are going to limit logins for 5-10 min, sorry for any inconveniences#smite
Posted about 1 year ago. Sep 14, 2016 - 15:28 EDT