Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This paladins pc incident has been resolved#paladinspc
Posted 5 months ago. May 14, 2017 - 17:01 EDT
Update
We are limiting logins for a few moments on Paladins PC #PaladinsPC
Posted 5 months ago. May 14, 2017 - 16:26 EDT
Identified
We are looking into issues for Paladins PC
Posted 5 months ago. May 14, 2017 - 16:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results. #PaladinsPC
Posted 5 months ago. May 14, 2017 - 15:58 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. May 14, 2017 - 15:37 EDT
This incident affected: Paladins PC.