Smite XBox Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 01, 2018 - 14:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Aug 01, 2018 - 14:25 EDT
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. Aug 01, 2018 - 14:15 EDT
Identified
We will be performing an emergency restart of Smite on XBox in a moment
Posted 4 months ago. Aug 01, 2018 - 14:14 EDT
Investigating
We are investigating an issue with Smite XBox that may affect players trying to log into the game
Posted 4 months ago. Aug 01, 2018 - 14:12 EDT
This incident affected: Smite (Smite Xbox).