Smite PC Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Smite #PC has been resolved. We apologize for the inconvenience.
Posted 5 months ago. May 30, 2018 - 21:43 EDT
Investigating
We are investigating an issue with #Smite #PC.
Posted 5 months ago. May 30, 2018 - 21:14 EDT
This incident affected: Smite (Smite PC).