Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 01, 2016 - 16:44 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 6 months ago. Nov 01, 2016 - 16:38 EDT