Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #SmitePC has been resolved.
Posted 22 days ago. Jul 01, 2017 - 07:52 EDT
Monitoring
Monitoring - We have corrected an issue with #SmitePC and are continuing to monitor.
Jul 1, 20:06 EDT
Posted 22 days ago. Jul 01, 2017 - 07:07 EDT
Investigating
Investigating - Automated services have detected a possible problem with #SMITEPC. We are investigating.
Jul 1, 20:03 EDT
Posted 22 days ago. Jul 01, 2017 - 07:06 EDT
This incident affected: Smite PC - North America / Europe.